Page 1 of 1

Check Lua quarantine file?

Posted: Thu Sep 26, 2019 6:12 pm
by Geoffcfp
A little help if I could please.

Each time I start up 124thATC-a60RC53 I get an announcement to check my lua quarantine scripts.

Any idea what that is all about?

Thanks from a newbie

Re: Check Lus quarantine file?

Posted: Thu Sep 26, 2019 7:27 pm
by RandomUser
Faulty LUA script; not 124th ATC's fault.

Re: Check Lus quarantine file?

Posted: Thu Sep 26, 2019 10:09 pm
by Geoffcfp
The alert is in the 1224thATC voice. Not interested in fault - only what can be done about it. The only script I have in quarantine is the "export_124thATC.lua" one. I have tried moving that into active scripts and still get the same alert.

Re: Check Lus quarantine file?

Posted: Fri Sep 27, 2019 9:03 pm
by RandomUser
Geoffcfp wrote:
Thu Sep 26, 2019 10:09 pm
The alert is in the 1224thATC voice. Not interested in fault - only what can be done about it. The only script I have in quarantine is the "export_124thATC.lua" one. I have tried moving that into active scripts and still get the same alert.
That means it's broken and should not be used, hence the quarantine folder.

124th ATC uses the same text to speech provider as X-Plane and, by extension, FlyWithLua. Hence the same voice.

Re: Check Lua quarantine file?

Posted: Sat Sep 28, 2019 2:05 am
by ntnll
export_124thATC.lua is a lua script for EFASS, not for x-plane, read the manual. 124thATC doesn't require lua, is pure C++

a.

Re: Check Lua quarantine file?

Posted: Sat Sep 28, 2019 3:17 am
by Geoffcfp
My mystery has been solved - by the developer of FlyWithLua.

He most graciously, patiently and kindly asked for data, did some digging and pointed to the key error here. I was using an outdated version of FWL!

Problem solved and much appreciated by an aging senior who is not really conversant with a lot of the technical ins and outs of things - just an enthusiastic user looking to enjoy the experiences XP and plugins like your can help us appreciated and experience.

Thank you

Geoff

Re: Check Lua quarantine file?

Posted: Sat Sep 28, 2019 8:26 am
by ntnll
Geoffcfp wrote:
Sat Sep 28, 2019 3:17 am
My mystery has been solved - by the developer of FlyWithLua.

He most graciously, patiently and kindly asked for data, did some digging and pointed to the key error here. I was using an outdated version of FWL!

Problem solved and much appreciated by an aging senior who is not really conversant with a lot of the technical ins and outs of things - just an enthusiastic user looking to enjoy the experiences XP and plugins like your can help us appreciated and experience.

Thank you

Geoff
Hi Geoff,
I'm happy you solved. But I still believe there something incorrect in your configuration. Is that file you mentioned, the lua script you found in my 124tATC package? If yes, this file do not need to be installed in flight with lua! This file is meant to be used in EFASS 2, in order to enable the compatibility for exporting flight plans in 124thATC, as described in my the plugin documentation. Have a look here. If you don't use EFASS, you don't need to install this file. And the file anyway needs to be installed in the EFASS folder, not in flight with lua.

Re: Check Lua quarantine file?

Posted: Sat Sep 28, 2019 5:35 pm
by Geoffcfp
Yes I did put that file in FWL without even knowing what EFASS is.

It is not installed there anymore.

No more problems for the moment

Thanks