Release Candidate (RC) Version - Download and Feedback

Forum dedicated to the alpha, beta, and RC versions
RandomUser
Posts: 73
Joined: Fri Aug 31, 2018 10:15 pm

Re: RCs public previews

Post by RandomUser » Sun May 05, 2019 11:05 pm

Just had a program crash with rc31, flying EDDT - EFHK, shortly before HK891 (at 60° 16' 24.62" N 25° 5' 18.64" E) on the DIVA2A STAR for runway 22L.
Before, 124th wanted to guide me away from the STAR, but I ignored the heading calls.
AIRAC1902 for everything (X-Plane 11.33, 124th, Little Navmap).

The bug report is attached.

Generally, it would be nice if ATC did not give any heading instructions at all when fyling SIDs and STARs without any major deviation, only (timely) altitude clearances.
You do not have the required permissions to view the files attached to this post.

Wulfkai
Posts: 2
Joined: Sun Apr 07, 2019 8:51 pm

Re: RCs public previews

Post by Wulfkai » Mon May 06, 2019 10:49 am

RandomUser wrote:
Sun May 05, 2019 11:05 pm
Just had a program crash with rc31, flying EDDT - EFHK, shortly before HK891 (at 60° 16' 24.62" N 25° 5' 18.64" E) on the DIVA2A STAR for runway 22L.
Before, 124th wanted to guide me away from the STAR, but I ignored the heading calls.
AIRAC1902 for everything (X-Plane 11.33, 124th, Little Navmap).

The bug report is attached.

Generally, it would be nice if ATC did not give any heading instructions at all when fyling SIDs and STARs without any major deviation, only (timely) altitude clearances.
Go in settings, the right side there is a option regarding the amount of heading calls ;)

ntnll
Posts: 593
Joined: Sun May 13, 2018 12:32 pm

Re: RCs public previews

Post by ntnll » Mon May 06, 2019 11:02 am

v2.0-a60RC32 available. Lot of minor bugs fixed.
124thATC Developer

Wulfkai
Posts: 2
Joined: Sun Apr 07, 2019 8:51 pm

Re: RCs public previews

Post by Wulfkai » Mon May 06, 2019 11:50 am

I keep getting "shenyang departure" when departing from oslo gardermoen airport, and i cant seem to find the place in the manuel where it tells how to change this to the correct one.. im using aerosoft oslo airport?

any help would be much appreciated :)

vittop
Posts: 109
Joined: Tue Dec 11, 2018 7:50 am

Re: RCs public previews

Post by vittop » Mon May 06, 2019 2:35 pm

ntnll wrote:
Mon May 06, 2019 11:02 am
v2.0-a60RC32 available. Lot of minor bugs fixed.
Retried KPAE->KCLM C172 via SEA ULESS ARRIE ELWHA. While whit 30 and 31 the issue happened after ULESS intersection (atc doesn't ask to turn toward ARRIE one), with 32 the issue happens at first supposed turn after SEA (a VOR), atc doesn't ask to turn toward ULESS intersection. Find attached the debug
bugReport.tar.gz
You do not have the required permissions to view the files attached to this post.
[Using XP11.41r1|Ubuntu 16.04.7\Mint 18.3|Kernel 4.15.0-99|amdgpu opensource driver|Mesa 18.0.5]

ntnll
Posts: 593
Joined: Sun May 13, 2018 12:32 pm

Re: RCs public previews

Post by ntnll » Mon May 06, 2019 4:05 pm

Wulfkai wrote:
Mon May 06, 2019 11:50 am
I keep getting "shenyang departure" when departing from oslo gardermoen airport, and i cant seem to find the place in the manuel where it tells how to change this to the correct one.. im using aerosoft oslo airport?

any help would be much appreciated :)
Please read this post.
a.
124thATC Developer

ntnll
Posts: 593
Joined: Sun May 13, 2018 12:32 pm

Re: RCs public previews

Post by ntnll » Mon May 06, 2019 4:13 pm

vittop wrote:
Mon May 06, 2019 2:35 pm
ntnll wrote:
Mon May 06, 2019 11:02 am
v2.0-a60RC32 available. Lot of minor bugs fixed.
Retried KPAE->KCLM C172 via SEA ULESS ARRIE ELWHA. While whit 30 and 31 the issue happened after ULESS intersection (atc doesn't ask to turn toward ARRIE one), with 32 the issue happens at first supposed turn after SEA (a VOR), atc doesn't ask to turn toward ULESS intersection. Find attached the debug

bugReport.tar.gz
Gi vittop,
I'm unable to replicate the issue, I get all the vectors. Are you using the 1x 2x 4x 8x 16x Sim speed for the tests?
124thATC Developer

vittop
Posts: 109
Joined: Tue Dec 11, 2018 7:50 am

Re: RCs public previews

Post by vittop » Mon May 06, 2019 5:07 pm

ntnll wrote:
Mon May 06, 2019 4:13 pm
vittop wrote:
Mon May 06, 2019 2:35 pm
ntnll wrote:
Mon May 06, 2019 11:02 am
v2.0-a60RC32 available. Lot of minor bugs fixed.
Retried KPAE->KCLM C172 via SEA ULESS ARRIE ELWHA. While whit 30 and 31 the issue happened after ULESS intersection (atc doesn't ask to turn toward ARRIE one), with 32 the issue happens at first supposed turn after SEA (a VOR), atc doesn't ask to turn toward ULESS intersection. Find attached the debug

bugReport.tar.gz
Gi vittop,
I'm unable to replicate the issue, I get all the vectors. Are you using the 1x 2x 4x 8x 16x Sim speed for the tests?
Yes, mainly to gain altitude quickly. Anyhow I retried, this time departing from rwy not from parking. I had a crash after t/o authorization, here is the debug
bugReport2.tar.gz
Note: I upgraded to 11.33, may be this the reason of different behaviour between our tests?
You do not have the required permissions to view the files attached to this post.
[Using XP11.41r1|Ubuntu 16.04.7\Mint 18.3|Kernel 4.15.0-99|amdgpu opensource driver|Mesa 18.0.5]

ntnll
Posts: 593
Joined: Sun May 13, 2018 12:32 pm

Re: RCs public previews

Post by ntnll » Mon May 06, 2019 5:55 pm

vittop wrote:
Mon May 06, 2019 5:07 pm
ntnll wrote:
Mon May 06, 2019 4:13 pm
vittop wrote:
Mon May 06, 2019 2:35 pm


Retried KPAE->KCLM C172 via SEA ULESS ARRIE ELWHA. While whit 30 and 31 the issue happened after ULESS intersection (atc doesn't ask to turn toward ARRIE one), with 32 the issue happens at first supposed turn after SEA (a VOR), atc doesn't ask to turn toward ULESS intersection. Find attached the debug

bugReport.tar.gz
Gi vittop,
I'm unable to replicate the issue, I get all the vectors. Are you using the 1x 2x 4x 8x 16x Sim speed for the tests?
Yes, mainly to gain altitude quickly. Anyhow I retried, this time departing from rwy not from parking. I had a crash after t/o authorization, here is the debug

bugReport2.tar.gz

Note: I upgraded to 11.33, may be this the reason of different behaviour between our tests?

I upgraded too. I don't get the crashes, either the missing vectors, I'll keep trying anyway. The sim speed can definitely causes the missing vectors calls though
a.
124thATC Developer

RandomUser
Posts: 73
Joined: Fri Aug 31, 2018 10:15 pm

Re: RCs public previews

Post by RandomUser » Mon May 06, 2019 6:33 pm

Wulfkai wrote:
Mon May 06, 2019 10:49 am
Go in settings, the right side there is a option regarding the amount of heading calls ;)
Ooops. Didn't have it activated.

oncleseb
Posts: 9
Joined: Sat Apr 27, 2019 4:04 pm

Re: Altitude cleared does not match with Maps

Post by oncleseb » Mon May 06, 2019 11:25 pm

ntnll wrote:
Sun May 05, 2019 5:11 pm
oncleseb wrote:
Sat May 04, 2019 6:19 am
Hi Antonello,
Flight KMIA to KSRQ, FL140, no SID no STAR selected.
But, in order to test, I chose to flight, just after take take-off, to WINCO fix point.
On maps, altitude at WINCO is limited to 5000, because WINCO belongs to KMIA SID fix points.
124th has cleared me to 7000 !
(After, cleard me to FL140, ok !)
Sebastien
Hi Sebastien,

First of all mentioning that apparently you're filing a SID fixes in the flight plan (WINCO2). You should avoid to file SIDs, STARs or airports in the flight plan. I added anyway a sanity check in the current build I'm working on, in order to prevent such errors.

Second thing I noticed, you don't request the plugin to look for SID and STARS, so no one restriction will be searched anyway without select the SID/STAR search box.

Last point, I don't find trace of such FL restriction in the navdata I'm using (KMIA.dat cycle 1901). Also my flight planner EFASS doesn't show any restriction at any FIX along the SID WINCO2. What charts are you using for plan your flight?

a.
Hi Antonello,
Thx for your feed back.
My goal was a short flight, don't requesting SID nor STARS. I undertand, in this case, not to include SID/STAR waypoints to avoid confusion.
KMIA SID WINCO2 : downloaded from : https://skyvector.com/airport/MIA/Miami ... al-Airport
Seb.

doc124
Posts: 14
Joined: Sat May 04, 2019 10:35 pm

Problem with 11.33

Post by doc124 » Tue May 07, 2019 4:05 am

I am using 124thATCv2.0-a60RC31 with 11.33 and it does not work at all. The plugin runs but it does not detect when I enter the clearance delivery frequency for any airport, Therefore, the flight plan dialog box does not appear. Also, trying to select a particular frequency from the dialog box in 124th ATC does not do anything. It worked fine in 11.32.

toelg
Posts: 11
Joined: Wed Jun 13, 2018 12:09 pm

Re: Problem with 11.33

Post by toelg » Tue May 07, 2019 9:28 pm

doc124 wrote:
Tue May 07, 2019 4:05 am
I am using 124thATCv2.0-a60RC31 with 11.33 and it does not work at all. The plugin runs but it does not detect when I enter the clearance delivery frequency for any airport, Therefore, the flight plan dialog box does not appear. Also, trying to select a particular frequency from the dialog box in 124th ATC does not do anything. It worked fine in 11.32.
Exactly the same at me, I have added the bugReport.
Also noticed, although I have installed RC32, there is still RC31 at the log.txt
bugReport.7z
You do not have the required permissions to view the files attached to this post.

ntnll
Posts: 593
Joined: Sun May 13, 2018 12:32 pm

Re: Problem with 11.33

Post by ntnll » Wed May 08, 2019 8:39 am

toelg wrote:
Tue May 07, 2019 9:28 pm
doc124 wrote:
Tue May 07, 2019 4:05 am
I am using 124thATCv2.0-a60RC31 with 11.33 and it does not work at all. The plugin runs but it does not detect when I enter the clearance delivery frequency for any airport, Therefore, the flight plan dialog box does not appear. Also, trying to select a particular frequency from the dialog box in 124th ATC does not do anything. It worked fine in 11.32.
Exactly the same at me, I have added the bugReport.
Also noticed, although I have installed RC32, there is still RC31 at the log.txt

bugReport.7z
Exactly the same, but with a log attached, which allows me to investigate. Thanks for reporting toelg, I'll have a look into it. Unfortunately I'm not able to replicate the issue on 11.33+RC32.
124thATC Developer

toelg
Posts: 11
Joined: Wed Jun 13, 2018 12:09 pm

Re: Problem with 11.33

Post by toelg » Wed May 08, 2019 6:03 pm

Hi Antonello.
ntnll wrote:
Wed May 08, 2019 8:39 am
Unfortunately I'm not able to replicate the issue on 11.33+RC32.
that makes it difficult. At xplane.org (XP11 General dicussion), there is the same experience, some users have also this problem and others not.

However, here are some observations (at EDDL) : The flight plan dialog box appears always at "Tower" and not at "Delivery". "Tower" is the only checkbox, which sets a frequency. But for EDDL it is the wrong frequeny (126.85 instead of 118.30). ATIS has the right frequency (123.77), but I have to set the frequency manually.

Hope this information can help to fix the bug.

Thanks
Dietmar

Post Reply