ATC stops talking

Any problem or bug related to 124thATC
Post Reply
jgplarnold
Posts: 20
Joined: Thu Apr 11, 2019 12:22 am
Location: Sydney, Australia

ATC stops talking

Post by jgplarnold » Sat Apr 13, 2019 2:48 am

I have repeated this many times and always the same reult - ATC stops talking when I click on 'request engine startup and pushback'.
I am using the Zibo modified B738 and this is what happens
I start the APU etc
Click on 'File Flightplan' and enter required information
Click on 'Request IFR clearance' and ATC responds with 'Cleared to YSSY ... etc and the transponder code' which I set
Click on 'Other Runway' and select a different runway (as the one allocated by ATC is too short) and ATC responds with 'Cleared to YSSY ...etc' with the new runway and transponder code/
Click on 'Engine Startup and pushback' - ATC does NOT respond yet the 'input' box displays 'Readback and 'Say Again'. I click on 'say again' and still nothing from ATC.
Althought I am using 'auto frequencies' I manually selected every possible radio contact and still nothing from ATC.
I have attached the bugreport.
Thanks.

Added later
In an effort to attempt to resolve this myself I tried ALL of the following with no improvement-
Removed plugin (deleted the 124thATC folder from plugins) and reinstalled
Selected Request Engine Startup instead of Request Engine Startup and Pushback
Also tried accepting the original assigned runway instead of 'other runway'.

Not sure what else I can do.
bugReport.rar
You do not have the required permissions to view the files attached to this post.

ntnll
Posts: 308
Joined: Sun May 13, 2018 12:32 pm

Re: ATC stops talking

Post by ntnll » Tue Apr 16, 2019 9:44 am

jgplarnold wrote:
Sat Apr 13, 2019 2:48 am
I have repeated this many times and always the same reult - ATC stops talking when I click on 'request engine startup and pushback'.
I am using the Zibo modified B738 and this is what happens
I start the APU etc
Click on 'File Flightplan' and enter required information
Click on 'Request IFR clearance' and ATC responds with 'Cleared to YSSY ... etc and the transponder code' which I set
Click on 'Other Runway' and select a different runway (as the one allocated by ATC is too short) and ATC responds with 'Cleared to YSSY ...etc' with the new runway and transponder code/
Click on 'Engine Startup and pushback' - ATC does NOT respond yet the 'input' box displays 'Readback and 'Say Again'. I click on 'say again' and still nothing from ATC.
Althought I am using 'auto frequencies' I manually selected every possible radio contact and still nothing from ATC.
I have attached the bugreport.
Thanks.

Added later
In an effort to attempt to resolve this myself I tried ALL of the following with no improvement-
Removed plugin (deleted the 124thATC folder from plugins) and reinstalled
Selected Request Engine Startup instead of Request Engine Startup and Pushback
Also tried accepting the original assigned runway instead of 'other runway'.

Not sure what else I can do.

bugReport.rar
Hi jgplarnold,
If you request the IFR and authorization to takeoff directly from the runway, skipping all the engine/taxi/pushback phase, does the issue occur?
124thATC Developer

jgplarnold
Posts: 20
Joined: Thu Apr 11, 2019 12:22 am
Location: Sydney, Australia

Re: ATC stops talking

Post by jgplarnold » Tue Apr 16, 2019 10:51 am

If I ignore the fact that I do not get a clearance to pushback and start engines (click on readback), the next prompt is 'request taxi' and if I click on that I do not get a clearance to taxi just a readback prompt.
If I start a session on the runway with engines not started (just the apu running) the same things happens as described.
If I start a session on the runway with engines already started after filing flight plan and request IFR departure, setting transponder code the next prompt from atc is to contact Tower for departure.

added later
I have tried this using the stock standard B737 from Laminar (I normally use the Zibo midified B727) and the same thing happens.

ntnll
Posts: 308
Joined: Sun May 13, 2018 12:32 pm

Re: ATC stops talking

Post by ntnll » Wed Apr 17, 2019 10:20 am

jgplarnold wrote:
Tue Apr 16, 2019 10:51 am
If I ignore the fact that I do not get a clearance to pushback and start engines (click on readback), the next prompt is 'request taxi' and if I click on that I do not get a clearance to taxi just a readback prompt.
If I start a session on the runway with engines not started (just the apu running) the same things happens as described.
If I start a session on the runway with engines already started after filing flight plan and request IFR departure, setting transponder code the next prompt from atc is to contact Tower for departure.

added later
I have tried this using the stock standard B737 from Laminar (I normally use the Zibo midified B727) and the same thing happens.
Did you tried to disable the squawk check in the plugin options?
124thATC Developer

jgplarnold
Posts: 20
Joined: Thu Apr 11, 2019 12:22 am
Location: Sydney, Australia

Re: ATC stops talking

Post by jgplarnold » Thu Apr 18, 2019 12:12 am

Setting 'Check Squawk Code' ON or OFF makes no difference.
I have been doing some more testing and found that the problem I listed ONLY happens when my departure airport is YSCB (Canberra). If I depart from YSSY (Sydney) there are NO problems.
I don't know what differences there are between these two airports. YSSY is a large airport with 3 runways and YSCB is smaller with only 2 runways.

ALSO please nore that when departing YSCB and ATC clears me to the arrival airport (YSSY) the last message is "Contact ME when ready to startup" whereas when departing YSSY ATC tells me to "contact Ground when ready to startup".
Also note that using plugin Airport Navigator to display COMM frequencies for YSSY it displays ground as GND but for YSCB it displays CANBERRA GROUND CLD as well as CANBERRA GROUND (both with the same frequencies).
I hope this helps solve this apparent bug.


I have found another problem.
When I decided to fly the return flight (from the original destination airport to the original departure airport) I started a new flight (without exiting XP), entered the new data into the FMS together with the new waypoints BUT when I did a 'file flight plan' and clicked on IMPORT FROM FMS it did not display the correct waypoints from the FMS. It displayed something very strange. I have attached screen shots
124thatc fp.jpg
.
124thatc fms1.jpg
124thatc fms2.jpg
Keep up the great work.
You do not have the required permissions to view the files attached to this post.

jgplarnold
Posts: 20
Joined: Thu Apr 11, 2019 12:22 am
Location: Sydney, Australia

Re: ATC stops talking

Post by jgplarnold » Thu Apr 18, 2019 8:11 am

Found the problem.
When I removed custom scenery YSCB tdg 124thATC works correctly (ATC tells me to contact GROUND when ready for startup instead of contact ME AND I get clearance to starup).
Any ideas why this custom scenery would cause 124thATC to not work correctly? I have all the libraries required installed.

ntnll
Posts: 308
Joined: Sun May 13, 2018 12:32 pm

Re: ATC stops talking

Post by ntnll » Thu Apr 18, 2019 11:52 am

jgplarnold wrote:
Thu Apr 18, 2019 8:11 am
Found the problem.
When I removed custom scenery YSCB tdg 124thATC works correctly (ATC tells me to contact GROUND when ready for startup instead of contact ME AND I get clearance to starup).
Any ideas why this custom scenery would cause 124thATC to not work correctly? I have all the libraries required installed.
The tower asks to contact back them again when no ground frequency are available.
Apparently your custom airport doesn't have the correct frequencies, have a look to this documentation paraghraph. Which custom airport are you using?


a.
124thATC Developer

jgplarnold
Posts: 20
Joined: Thu Apr 11, 2019 12:22 am
Location: Sydney, Australia

Re: ATC stops talking

Post by jgplarnold » Thu Apr 18, 2019 12:50 pm

I am using custom scenery with a name of "YSCB tdg" available here https://forums.x-plane.org/index.php?/f ... l-airport/. It is for Canberra airport here in Australia.

I have modified this reply many times and as I did not see a reply I assumed that you had not yet read it.
The following is all NEW to this reply.

I continued trying LOTS of different things and then I found out what I think is the problem.
Consider the following taken from the APT.DAT file for the frequencies.
50 12745 YSCB ATIS
51 11870 CANBERRA MULT
52 12170 CANBERRA GROUND CLD
53 12170 CANBERRA GND
54 11870 CANBERRA TWR
54 12590 MELBOURNE CENTRE CNTR
55 12450 CANBERRA APP
55 12590 CANBERRA APP

Notice that frequency 12170 is the SAME for two different frequency TYPES. I checked lots of other APT.DAT files for other customer sceneries and could not find duplicate frequencies for two diffeernt freqency types and so I changed the frequency for '52 12170 CANBERRA GROUND CLD' to something unique and then 124thATC didn't have the problem I originally encountered.

A bit tricky but at last I seem to have worked it out (I used to enjoy debugging programs when I was an analyst/programmer).
Am I correct in assuming that a particular frequency should NOT be used for two different frequenccy types?

Thanks for your help and patience.

jgplarnold
Posts: 20
Joined: Thu Apr 11, 2019 12:22 am
Location: Sydney, Australia

Re: ATC stops talking

Post by jgplarnold » Sun Apr 21, 2019 8:11 am

This reply is just to modify the date/time last updated as I modified my previous reply and the date posted remains the same. Just in case Antonello doesn't notice and thinks he has already replied.

The question asked is this -

Am I correct in assuming that a particular frequency should NOT be used for two different frequency types (in the APT.DAT file)?

Post Reply