Multivoice with Ivona voices

Any problem or bug related to 124thATC
johnbla
Posts: 14
Joined: Mon May 21, 2018 12:34 pm

Multivoice with Ivona voices

Post by johnbla » Wed Jun 06, 2018 6:56 am

Hi
I am trying to set up Multi voice with an Ivona voice. I have followed the procedure in the manual and I have listed the Ivona voice as the user as shown below:

user#IVONA 2 Voice Russell22
atc#TTS_MS_EN-US_ZIRA_11.0
ai01#TTS_MS_EN-GB_HAZEL_11.0
ai02#TTS_MS_en-AU_Hayley_11.0
ai03#TTS_MS_en-CA_Heather_11.0
ai04#TTS_MS_pl-PL_Paulina_11.0

However I still do not get the Ivona voice in ATC. I was wondering if anyone else out there who has an Ivona voice installed can see if I am doing anything wrong.

Voices.txt is attached.

Many thanks for any help.
John
Attachments
Voices.txt
(442 Bytes) Downloaded 51 times

ntnll
Posts: 186
Joined: Sun May 13, 2018 12:32 pm

Re: Multivoice with Ivona voices

Post by ntnll » Sat Jun 09, 2018 11:54 pm

Hi John,
I moved the thread in the appropriate forum. Please read this this before post. I need the Log.txt and the debug option enable in order to help
Last edited by ntnll on Wed Jan 02, 2019 3:14 pm, edited 3 times in total.

marcopol
Posts: 19
Joined: Mon May 14, 2018 8:49 am

Re: Multivoice with Ivona voices

Post by marcopol » Thu Jul 19, 2018 10:02 am

Care must be taken that the Voice-text file is recreated with the Notepad ++ software exclusively.

Holbud
Posts: 2
Joined: Wed Dec 26, 2018 2:20 pm

Re: Multivoice with Ivona voices

Post by Holbud » Wed Dec 26, 2018 2:30 pm

Hey johnbla,

Did you ever get this working, i am having the same issues as you.
No matter what voice i set it to it defaults to microsoft Ana even though the default voice in
speech recognition has been changed to another default voice in x86 and 64 bit voice engines.

johnbla
Posts: 14
Joined: Mon May 21, 2018 12:34 pm

Re: Multivoice with Ivona voices

Post by johnbla » Mon Dec 31, 2018 10:19 pm

No, I gave up. I would like to hear from anyone who has had success with this.

jkeye
Posts: 11
Joined: Tue May 22, 2018 5:48 pm

Re: Multivoice with Ivona voices

Post by jkeye » Tue Jan 01, 2019 11:11 am

I use cereproc voices and they seem fine

Holbud
Posts: 2
Joined: Wed Dec 26, 2018 2:20 pm

Re: Multivoice with Ivona voices

Post by Holbud » Wed Jan 02, 2019 10:13 am

Just letting people know that the ivona voices i have installed work great with pilot2atc so i assume it is a problem with 124th

ntnll
Posts: 186
Joined: Sun May 13, 2018 12:32 pm

Re: Multivoice with Ivona voices

Post by ntnll » Wed Jan 02, 2019 3:15 pm

ntnll wrote:
Sat Jun 09, 2018 11:54 pm
Hi John,
I moved the thread in the appropriate forum. Please read this this before post. I need the Log.txt and the debug option enable in order to help

johnbla wrote:
Mon Dec 31, 2018 10:19 pm
No, I gave up. I would like to hear from anyone who has had success with this.

I used them in the past without problems.
As mentioned a lot of time and previously in this thread, if you need help you need to enable debug mode and provide the log.txt.
Are you able to "Preview voice" for all the installed voices in the control panel? Are all them listed in the "Voice Selection" list? Can you provide a screenshot of the voices listed in the voice selection lsit, the last in use voice.txt, and the log.txt? Also if possible share your screenshot of the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Speech\Voices\Tokens\ installed keys (see here)


Image

johnbla
Posts: 14
Joined: Mon May 21, 2018 12:34 pm

Re: Multivoice with Ivona voices

Post by johnbla » Wed Jan 02, 2019 11:42 pm

ntll
Sorry about the log file, now attached, along with screenie of registry and speech recognition. For some reason I cannot attach voices.txt, so will add it here.

Debug mode is on. I can preview voice for all of the installed voices in the control panel and as you can see, I have two Ivona voices listed in the voice selection list.

My voices.txt is as follows:

user#IVONA 2 Voice Russell22
atc#
ai01#
ai02#
ai03#
ai04#
ai05#
ai06#
ai07#
ai08#
ai09#
ai10#
random01#IVONA 2 Voice Nicole22
random02#TTS_MS_EN-GB_HAZEL_11.0
random03#TTS_MS_EN-US_ZIRA_11.0
random04#
random05#
random06#
random07#
random08#
random09#
random11#
random12#
random13#
random14#
random15#

Many thanks for any help on this.
John
Attachments
Registry.jpg
Registry.jpg (87.61 KiB) Viewed 138 times
Speech recognition.docx
(346.08 KiB) Downloaded 4 times
Log.txt
(258.7 KiB) Downloaded 10 times

ntnll
Posts: 186
Joined: Sun May 13, 2018 12:32 pm

Re: Multivoice with Ivona voices

Post by ntnll » Thu Jan 03, 2019 10:18 am

I don't see errors in the configuration, all looks in place.
I'll make some tests at home and I'll tell you something else, meanwhile, just for exclude any permission issue, try do two different tests:

- disable Windows UAC for your user if still not disabled, so try again.
- run xp as administrator, so try again.

Let me know if the behave changes

edit: if possible please send me the whole bug report after a full flight

a.

johnbla
Posts: 14
Joined: Mon May 21, 2018 12:34 pm

Re: Multivoice with Ivona voices

Post by johnbla » Fri Jan 04, 2019 7:48 am

a

Still having the problem with uac off and running XP as an administrator. Bug report attached. Thanks for the help.

John
Attachments
bugReport.7z
(24.96 KiB) Downloaded 5 times

ntnll
Posts: 186
Joined: Sun May 13, 2018 12:32 pm

Re: Multivoice with Ivona voices

Post by ntnll » Fri Jan 04, 2019 7:48 pm

johnbla wrote:
Fri Jan 04, 2019 7:48 am
a

Still having the problem with uac off and running XP as an administrator. Bug report attached. Thanks for the help.

John
can you try this voice.txt and see if this the plugin swaps the voices correctly? I want to see if is just Ivona related issue or not:

Code: Select all

user#TTS_MS_EN-US_DAVID_11.0
atc#
ai01#
ai02#
ai03#
ai04#
ai05#
ai06#
ai07#
ai08#
ai09#
ai10#
random01#TTS_MS_EN-GB_HAZEL_11.0
random02#TTS_MS_EN-US_ZIRA_11.0
random03#
random04#
random05#
random06#
random07#
random08#
random09#
random11#
random12#
random13#
random14#
random15#

johnbla
Posts: 14
Joined: Mon May 21, 2018 12:34 pm

Re: Multivoice with Ivona voices

Post by johnbla » Sat Jan 05, 2019 2:51 am

a
I tried that voice.txt you posted and I get the same voice for pilot, tower and ground (I didn't go further).

BTY, my Ivona voices work fine with Pilot2ATC.
Regards
John

ntnll
Posts: 186
Joined: Sun May 13, 2018 12:32 pm

Re: Multivoice with Ivona voices

Post by ntnll » Tue Jan 08, 2019 10:03 pm

johnbla wrote:
Sat Jan 05, 2019 2:51 am
a
I tried that voice.txt you posted and I get the same voice for pilot, tower and ground (I didn't go further).

BTY, my Ivona voices work fine with Pilot2ATC.
Regards
John
Hi John,
is definitely strange. Please confirm the following:

- is the atis audible if you set the atis frequency (you can use the frequency selector dialog)? Which voice do you hear?
- is at least the main voice working in 124thATC?
- have been any other not Ivona voices worked in 124thATC as main voices or ATC voice?

a.

RandomUser
Posts: 18
Joined: Fri Aug 31, 2018 10:15 pm

Re: Multivoice with Ivona voices

Post by RandomUser » Wed Jan 09, 2019 5:47 pm

I only ever got Mark, Eva, Zira and David to run for voice output in 124th. Even the other voices from Microsoft-supplied language packs, like Hazel or Sean, only worked in Windows 10's "Speech" menu when I tried them.

The main registry locations for installed voices seem to be:

Code: Select all

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Speech\Voices\Tokens
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Speech_OneCore\Voices\Tokens
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\SPEECH\Voices\Tokens\
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Speech_OneCore\Voices\Tokens\
"Sean", for example, shows up at 3 out of 4 locations, the 4th one being "WOW6432Node\Microsoft\SPEECH\Voices\Tokens\". This is not where 124th looks, but it might play a role.

It might help if the entire registry path to the TTS voice could be set in voices.txt to help debug this.
\
\
\
\
- Edit: Can somebody find out where P2ATC looks for voices in the registry?
Because if Ivona voices work in P2ATC, they should also work in 124th.
And apparently P2ATC requires the 64bit version of an Ivona (or any other) voice.

Post Reply