No audio output (TTS) on Linux

Any problem or bug related to 124thATC
ntnll
Posts: 225
Joined: Sun May 13, 2018 12:32 pm

Re: No audio output (TTS) on Linux

Post by ntnll » Fri Mar 08, 2019 5:56 pm

hoover wrote:
Fri Mar 08, 2019 4:18 pm
Hi folks,

I have now install espeak-ng and it works ok from the command line (espeak-ng "Hello World" does just that).

However I'm still not getting voice output from the plugin, so I'm wondering if my XLinSpeech plugin is installed correctly as it's not listed in XP's "installed plugins" list. The compilation seems to have worked fine:

Code: Select all

$make lin64.xpl
make: 'lin64.xpl' is up to date.

$ ls -l /usr/games/xplane11/Resources/plugins/XLinSpeak/64/lin64.xpl 
-rwxr-xr-x 1 hoover hoover 56232 Mar  6 17:39 /usr/games/xplane11/Resources/plugins/XLinSpeak/64/lin64.xpl
Settings.txt:
...
ldd also shows no missing libraries for the xpl file, so I'm a bit stumped here what to try next.

Thanks in advance for your patience and advice :)

All the best, Uwe
Hi Uwe,
I don't drive the TTS from the plugin, is handled by XP SDK. So if the XP TTS works, 124th should works. Can you hear the ATIS voice when tuned the correct frequency on the radio? If I fine remember, also on Linux ATIS use the internal TTS, it should proves if XP is able to uses your TTS engine.

a.

hoover
Posts: 12
Joined: Wed Mar 06, 2019 5:04 pm

Re: No audio output (TTS) on Linux

Post by hoover » Sat Mar 09, 2019 7:54 am

Thanks a lot for your reply.

I'm getting some conflicting information from the x-plane / Linux subforum: It was stated there that the internal XP ATC doesn't use TTS, but sampled words that get rearranged into sentences as necessary:

https://forums.x-plane.org/index.php?/f ... nt=1611552

This kind of makes sense as the x-plane native "dumb" ATC rounds quite good while an espeak-ng "Hello World" sounds very much like Mr. Hawking's ghost :) (I can live with that because of the many great features of 124thATC)

Thanks again for the support & all the best,

Uwe

hoover
Posts: 12
Joined: Wed Mar 06, 2019 5:04 pm

Re: No audio output (TTS) on Linux

Post by hoover » Sat Mar 09, 2019 8:34 am

Hey guys,

I'm happy to report I got it to work, yay!!!

All I needed to do was to download the XLinSpeak binary plugin provided by uglydwarf in his announcement thread and use that instead of my self-compiled one (I guess that job is best left to the professionals :))

Now speech output is working just fine. The native X plane ATC voices sound better than what espeak-ng provides, but I read somewhere that you can tinker with those as well, so for now I'm very happy!

All the best,

Uwe

https://forums.x-plane.org/applications ... ?id=248660

RandomUser
Posts: 40
Joined: Fri Aug 31, 2018 10:15 pm

Re: No audio output (TTS) on Linux

Post by RandomUser » Sat Mar 09, 2019 2:16 pm

Congratulations.
If you happen to get a different TTS engine to work with speech-dispatcher, feel free to inform me. While espeak-ng works, it doesn't provide the best output.

ntnll
Posts: 225
Joined: Sun May 13, 2018 12:32 pm

Re: No audio output (TTS) on Linux

Post by ntnll » Sat Mar 09, 2019 9:24 pm

hoover wrote:
Sat Mar 09, 2019 7:54 am
Thanks a lot for your reply.

I'm getting some conflicting information from the x-plane / Linux subforum: It was stated there that the internal XP ATC doesn't use TTS, but sampled words that get rearranged into sentences as necessary:

Thanks again for the support & all the best,

Uwe
ATC communications are just wave files streamed, you can find those files in the xplane installation. But, as far as I know, the ATIS uses TTS. Definitely on windows, but I believe also on Linux

Post Reply