Waypoint +0 +0

Support for any problem or bug related to 124thATC
ntnll
Posts: 339
Joined: Sun May 13, 2018 12:32 pm

Re: Waypoint +0 +0

Post by ntnll »

I can't reproduce the issue on my computer.
I'm using X-Plane 11.50r3 and AIRAC 2013, I don't get any +0 +0 waypoint...
124thATC Developer
tomkater68
Posts: 4
Joined: Mon Dec 28, 2020 1:56 pm

Re: Waypoint +0 +0

Post by tomkater68 »

I still have the problem with waypoint +0 +0 with X-Plane 11.50 R3 and default X-Plane data
124thATC v2.0-a61 23:05:27: C:\X-Plane 11\Custom Scenery
124thATC v2.0-a61 23:06:12: checking C:\X-Plane 11\Resources\plugins\124thATC64\navdata\earth_nav.dat version
124thATC v2.0-a61 23:06:12: earth_nav.dat version: 1802
124thATC v2.0-a61 23:06:12: reading earth_nav.dat from C:\X-Plane 11\Resources\plugins\124thATC64\navdata\earth_nav.dat
124thATC v2.0-a61 23:06:12: parseSingleNavDat: ILS scanning... C:\X-Plane 11\Resources\plugins\124thATC64\navdata\earth_nav.dat
124thATC v2.0-a61 23:06:12: reading xp11 earth_nav.dat format C:\X-Plane 11\Resources\plugins\124thATC64\navdata\earth_nav.dat
124thATC v2.0-a61 23:06:13: checking C:\X-Plane 11\Resources\plugins\124thATC64\navdata\earth_fix.dat version
124thATC v2.0-a61 23:06:13: earth_fix.dat version: 1802
Do I have to buy Navdata Updates to get rid of this problem? If so, which product do you recommend?

Regards

Michael
BC446BG
Posts: 20
Joined: Mon Oct 26, 2020 1:44 pm

Re: Waypoint +0 +0

Post by BC446BG »

Any news on the patch for this??
ntnll
Posts: 339
Joined: Sun May 13, 2018 12:32 pm

Re: Waypoint +0 +0

Post by ntnll »

BC446BG wrote: Sat Jan 02, 2021 12:59 am Any news on the patch for this??
no yet unfortunately.

Guys I can't really replicate the navdata issue even using the last navdata 11.50. Can anybody please share a log.txt and the flighPlan.kml file collected AFTER getting the issue, and send it to me please?
124thATC Developer
vittop
Posts: 14
Joined: Tue Dec 11, 2018 7:50 am

Re: Waypoint +0 +0

Post by vittop »

ntnll wrote: Sat Jan 09, 2021 2:58 pm
BC446BG wrote: Sat Jan 02, 2021 12:59 am Any news on the patch for this??
no yet unfortunately.

Guys I can't really replicate the navdata issue even using the last navdata 11.50. Can anybody please share a log.txt and the flighPlan.kml file collected AFTER getting the issue, and send it to me please?
Here we go. Tested during weekend. Now I run XP11.51 but as you'll see, same issue as 11.50. Switched back again to 11.41 navdata to temporarily fix.
Log.txt.zip
FlightPlan.kml.zip
You do not have the required permissions to view the files attached to this post.
[Using XP11.52r1|Linux Mint 20.1|Kernel 5.4.0-65|amdgpu opensource driver|Mesa 20.2.6]
BC446BG
Posts: 20
Joined: Mon Oct 26, 2020 1:44 pm

Re: Waypoint +0 +0

Post by BC446BG »

Anything new re this? thanks....
tomkater68
Posts: 4
Joined: Mon Dec 28, 2020 1:56 pm

Re: Waypoint +0 +0

Post by tomkater68 »

I also had this problem, but with a fresh X-Plane 11 installation without any plugins (except for 124thATC) and costum sceneries I can't reproduce it any longer (even with 11.50 navdata). Now I will try to reinstall plugins and sceneries and see, if this issue comes back.
-----------------
Edit: happy to early. Problem is back without any other plugins and costum sceneries and Navigraph doesn't offer 11.41 nav data any longer. :(
tlchristy
Posts: 5
Joined: Sun Dec 06, 2020 6:41 pm

Re: Waypoint +0 +0

Post by tlchristy »

Hello

I have attached my 0,0 waypoint flight from KPHL to KMCO. Just as I reached NOBBS in the CWRLD4 Star I am instructed to turn left heading 115 instead of an assumed right 275 for ILS Runway 35L...

Please find the Log.txt and LastFlightPlan.txt attached. I did not produce a KML file

*****
124thATC v2.0-a62RC4 11:53:45: Next navigation point: 20 NOBBS ... Lat: 28.164444 Lon: -81.187500
124thATC v2.0-a62RC4 11:54:40: DEBUG: Checking obstacles...
124thATC v2.0-a62RC4 11:55:40: DEBUG: Checking obstacles...
124thATC v2.0-a62RC4 11:56:40: DEBUG: Checking obstacles...
124thATC v2.0-a62RC4 11:56:47: Waypoint switch cause: fix reached. Old navigation point 20 NOBBS. Fix reached at speed: 130, next heading diff: 2.71
124thATC v2.0-a62RC4 11:56:47: Next navigation point: 21 ILS ... Lat: 0.000000 Lon: 0.000000
124thATC v2.0-a62RC4 11:56:47: Communication: Jetblue 1161, turn left heading 115.
*****

The 11.40 version of the navdata is no longer available at navigraph...
You do not have the required permissions to view the files attached to this post.
RandomUser
Posts: 39
Joined: Fri Aug 31, 2018 10:15 pm

Re: Waypoint +0 +0

Post by RandomUser »

Looks like the waypoint logic for ILS approaches is broken and can only be unbroken by completely ignoring instructions.

Code: Select all

124thATC v2.0-a61 23:47:46: Waypoint switch cause: fix reached. Old navigation point 13 LANAK. Fix reached at speed: 170, next heading diff: 4.55
124thATC v2.0-a61 23:47:46: Next navigation point: 14 ILS ... Lat: -0.000000 Lon: 0.000000

...

124thATC v2.0-a61 23:59:46: Waypoint switch cause: lost fix. Old navigation point 14 ILS. Fix reached at speed: 136, next heading diff: 106.05
124thATC v2.0-a61 23:59:46: Next navigation point: 15 Runway 05 ... Lat: 55.863480 Lon: -4.449060
To easily fix this, I'd simply have ATC calculate virtual waypoint 10 nm away from the runway treshhold (using runway heading) and vector the user aircraft there.
Actually, while we're at it: Not provide any vectors at all, only altitude clearances, when user is is flying a STAR.
You do not have the required permissions to view the files attached to this post.
kingjimbo
Posts: 1
Joined: Sat Feb 06, 2021 1:40 pm

Re: Waypoint +0 +0

Post by kingjimbo »

Not sure if this helps but I run X-plane on a pc and an iMac, I have all the problems discussed here with 124th ATC on my pc and have found it very frustrating. I now only fly on the iMac. For some reason 124th ATC operates flawlessly with all the latest navdata on the iMac, even DCT approaches work and the default FMS updates automatically when I readback to the 124th ATC controller. I've tried copying the navdata from the iMac to the pc so I have identical sets on both machines but the pc still messes up the approaches with weird waypoints. So for now I've given up on the pc. The iMac is fine except I get the occasional stutter loading complex orbx scenery through my egpu when panning views. On a final note, 124th ATC really brings X-plane to life for me, huge thanks to the developer for this wonderful plugin! Integration with global traffic would make it perfect!
tlchristy
Posts: 5
Joined: Sun Dec 06, 2020 6:41 pm

Re: Waypoint +0 +0

Post by tlchristy »

Crossing into airport airspace at 15,000 FT AGL (Above Ground Level) and 40NM doesn't help matters either. Being vectored to cross your ILS approach and being cleared to land while technically still facing down wind is another. The Waypoint +0 +0 bug is ignorable most of the time but the other 2 I just mentioned have always been issues. The odd cross restriction with a handover to approach at 15,000 AGL and no speed restriction should be cleared up first. Running 5nm distance parallel the active runway (downwind) should clear up the other...

There are things that can be improved like requesting a vector for airports that don't have STAR(s) relative to your approach position. KLEX in the States is like that. If you approach from KCVG you have a STAR (CLEGG5) but if you approach from the east from KCLT or KPHL you do not but the 124th holds you at FL160 (15,000 AGL - Ha Ha Ha) and flys you clear across the airport to an unrelated STAR position (CLEGG) miles away then brings you back in. All I am really saying is when manually selecting SID/STAR, Vector should always be a selectable option as well...
tlchristy
Posts: 5
Joined: Sun Dec 06, 2020 6:41 pm

Re: Waypoint +0 +0

Post by tlchristy »

On Approach to KMCO via the COSTR3 Star the last waypoint before what would be a vector to ILS Rwy 17R becomes a vector to the African Continent.
This 11.50 Nav Data problem has been around a while and the quick fix was using 11.40 which is no longer available...

Sorry Folks I do not see what the developer refuses to or simply can not see for himself - This plugin simply can not piece the last waypoint of a STAR to the ILS approach of runway. In my opinion the only thing that really works consistently is the post take off vector, I do not for the life of me understand why this is handled by Center rather than Departure but that is minor to this big headache...

*****
124thATC v2.0-a62RC4 19:19:38: Waypoint switch cause: fix reached. Old navigation point 24 KNUKL. Fix reached at speed: 231, next heading diff: 6.82
124thATC v2.0-a62RC4 19:19:38: Next navigation point: 25 ILS ... Lat: 0.000000 Lon: 0.000000
*****
You do not have the required permissions to view the files attached to this post.
BC446BG
Posts: 20
Joined: Mon Oct 26, 2020 1:44 pm

Re: Waypoint +0 +0

Post by BC446BG »

I agree entirely.. In my view, 124thATC is pretty much useless as it now stands
tomkater68
Posts: 4
Joined: Mon Dec 28, 2020 1:56 pm

Re: Waypoint +0 +0

Post by tomkater68 »

and the quick fix was using 11.40 which is no longer available...Sorry Folks I do not see what the developer refuses to or simply can not see for himself
The developer is aware of this problem and published 124thATC v2.0-a62RC5 today, which contains a first fix for this issue. So keep relaxed, download this version and test it.
Rafalec
Posts: 31
Joined: Mon May 14, 2018 5:52 pm
Location: Near Paris , France

Re: Waypoint +0 +0

Post by Rafalec »

This problem of Waypoint is a bug and to have the correction it is necessary to subscribe to Patreon, it is not logical to have to pay to have a bug correction!
MSI Z97 Gaming 5 - Intel I7 4790K - Artic cooling freezer 7 pro rev 2 - GSKILL 32 GO - SSD Crucial M5 120 go - HDD western digital caviar blue 1 TO - Gigabyte GTX 1070 gaming G1 - Windows 10 home 64 bits - XPlane 11.52 on Crucial SSD 2To
Post Reply